Xilinx Vivado 2017.4以降のバージョンでRiviera-PROをデフォルトシミュレータとして起動する方法

概要

本アプリケーションノートでは、Xilinx Vivado™ から Riviera-PROを起動して、ビヘイビアとタイミングシミュレーションを実行する方法を説明します。本ドキュメントでの動作はRiviera-PRO 2019.10とXilinx Vivado 2019.2、およびRiviera-PRO Simulator 1.18アドオンで確認を行っています。この統合により、ユーザはVHDL, Verilog, 混在言語およびSystemVerilog (Design) のシミュレーション実行のデフォルトシミュレータとしてRiviera-PROを使用することが可能です。

Riviera-PROアドオンのセットアップ

  1. VivadoのFlow Navigatorペインから呼び出すことが可能な、Settingsウィンドウの3rd Party SimulatorsカテゴリでRiviera-PROのインストールディレクトリパスを設定します。または、PATH環境変数にRiviera-PROのインストールディレクトリを追加します。Vivado環境からの設定は、環境変数で指定されたパスよりも優先されます。

    注意: PATH環境変数の変更時にVivadoがすでに実行されている場合は、Vivadoを再起動して新しいPATH変数をVivado内で有効にする必要があります。

  2. ToolsメニューからXilinx Tcl Storeオプションを選択し、Installedタブに切り替えてRiviera-PRO Simulatorプラグインがインストールされていることを確認します。インストールされていない場合は、All タブでプラグインを探し、Installボタンをクリックします。プラグインがインストールされている場合は、最新のバージョンにアップデートすることができます。アップデートは、Refreshボタンでリポジトリを更新した後、Updateボタンをクリックしてください。

Riviera-PROにXilinxライブラリのインストール

正常にシミュレーションを実行するには、デザインに関連するXilinx VIVADOバージョンのVHDL、Verilogまたは両方のシミュレーションライブラリをRiviera-PROにインストールする必要があります。現在インストールされているライブラリの確認は、ご使用頂いていますRiviera-PROバージョンのLibrariesウィンドウで確認できます。このウィンドウは、"Design Management"ツールバーのLibrariesボタン、またはViewメニュー|Design ManagementLibrariesオプションから起動できます。ライブラリは使用するRiviera-PROのバージョン用にコンパイルされている必要があります。

ライブラリを入手するいくつかの方法:

  1. VivadoのToolsメニューのCompile Simulation Librariesオプション、または"compile_simlib -simulator riviera"コマンドを使用して、ソースからXilinxライブラリをコンパイルすることが可能です。

    注意:  Xilinxからコンパイルしたライブラリを生成した後、Riviera-PRO環境にアタッチする必要があります。詳細については、「Xilinx Vivado シミュレーションライブラリをRiviera-PRO用にコンパイルする方法」を参照してください。

    プリコンパイルされたライブラリをインストールすることも可能です:

  2. Riviera-PROのダウンロードリンクを受信している場合、同じページにXilinx ライブラリをダウンロードするリンクがあります。

  3. いつでも最新のザイリンクスライブラリをダウンロード可能なアップデートセンターに訪問することが可能です。 http://www.aldec.com/jp/downloads.

Vivado からRiviera-PROを起動するための一般的な手順:

  1. Xilinx VivadoのProject Managerでプロジェクトを作成または開きます。

  2. Flow NavigatorペインからSettingsタブを選択します。

  3. SettingsウィンドウのSimulationカテゴリで、Target SimulatorRiviera-PRO Simulatorに変更します。

  4. プロジェクトで使用するライブラリは、Riviera-PROまたはVivado環境で指定する必要があります。 詳細については、 「Xilinx Vivado シミュレーションライブラリをRiviera-PRO用にコンパイルする方法」を参照してください。

  5. Compilationタブ内で、カバレッジ解析やデバッグモードなどのVerilogとVHDLコンパイラ機能の有効化、およびGenerics/Parameters値を割り当てたりすることができます。Generics/ParametersはGenerics/Parametersオプションフィールドで設定可能で、機能は利用可能なコンパイルオプションのリストから選択できます。

    注意: VHDLファイルのコンパイル時にLRMの厳格なチェックを緩和する必要がある場合には、riviera.compile.vhdl_relaxチェックボックスにチェックを入れます。

  6. ElaborationSimulationタブでは、シミュレーションに関連した引数を設定することができます。たとえば、すべての信号をシミュレーションデータベースに記録、信号へのアクセス権、シミュレーションの実行時間など

  7. すべての必要なオプションの設定が完了したらOKをクリックします。

    注意: シミュレーション作業中にRiviera-PROのバージョンが更新された場合、Riviera-PROの以前のバージョンで作成されたファイルを削除するために、SimulationカテゴリのAdvancedタブにあるEnable incremental compilationオプションをオフにする必要があります。

  8. Flow managerパネルからRun Simulationアイテムをクリックし、実行したいシミュレーションのタイプを選択します。これにより、シミュレーションがGUIモードで実行されます。

    または、コンソールモードでシミュレーションを実行することもできます。 これを行うには、Vivado Tcl Consoleウィンドウで次のコマンドを入力します:

    launch_simulation -batch -install_path

  9. 上記の手順で指定した設定に基づいて、Vivadoはコンパイルおよびシミュレーション用のDOマクロスクリプトを生成し、それらを<project_dir>\<project_name>.sim\<simulation_set>\<simulation_type>\rivieraディレクトリに保存します。

    • コンパイルマクロ (<name>_compile.do)は、デザインのコンパイル先となる作業ライブラリをセットアップし、Xilinx Vivadoライブラリをマップし、Project Settings | Simulation | Compilationで指定されたオプションを使用してコンパイルを実行します。

    • シミュレーションマクロ (<name>_simulation.do)は、イニシャライズとシミュレーションデータベース(ASDB)に信号履歴を記録しながらシミュレーションセッションを実行します。

  10. Aldecのコンパイラは、選択したモードに関係なく、コンソールでコンパイルマクロを実行します。コンパイラの出力はVivado Tcl Consoleウィンドウにリダイレクトされます。

  11. コンパイルが正常に終了すると、Riviera-PROが起動し、シミュレーションマクロが実行されます。マクロは初期化と信号履歴をシミュレーションデータベース(ASDB)に記録しながらシミュレーションセッションを実行します。GUIモードでは、シミュレーションが完了すると信号の履歴が波形ビューアーに表示されます。この時点で、矢印キーを使用してConsoleウィンドウの履歴をナビゲートし、シミュレーションマクロから任意のコマンドを再実行することができます。デザインソースを参照するには、Libraryウィンドウでライブラリアイテムを展開した後に検査できるデザインユニットのコンテキストメニューからShow Sourceオプションを使用します。バッチモードでは、シミュレータの出力がVivado Tcl Consoleにリダイレクトされ、シミュレーションの完了後にRiviera-PROが閉じられます。

export_simulationコマンド

export_simulationコマンドを使用すると、Vivadoで生成されたコンパイルマクロとシミュレーションマクロを-run_dir引数で指定されたディレクトリにエクスポートできます。 エクスポートされるマクロは、-mode引数と-type引数で示されます。

Syntax

tclapp::aldec::riviera::export_simulation -run_dir [-lib_map_path] [-mode] [-type] [-quiet] [-verbose]

Arguments

-run_dir

-modeおよび-type引数で選択されたマクロがエクスポートされるディレクトリを指定します。

-lib_map_path

プリコンパイルされたシミュレーションライブラリを含むディレクトリを指定します。

-mode

シミュレーションモードを設定します。 次のモードが許可されます:behavioral, post-synthesis, post-implementationの各パラメータで、ビヘビア、ポストシンセシス、ポストインプリメンテーションを選択出来ます。

-type

ネットリストタイプを指定します。 許可される値は機能とタイミングです。 この引数は、選択したシミュレーションモードがポストシンセシス、ポストインプリメンテーション(-modeでpost-synthesis、またはpost-implementationが設定)の場合にのみ適用されます。

-quiet

コマンドによって報告されたエラーメッセージの表示を抑止します。

-verbose

コマンドの実行中にコンソールに表示されるメッセージの制限を解除します。



Printed version of site: www.aldec.com/jp/support/resources/documentation/articles/2036