Starting Active-HDL as the Default Simulator in Microsemi Libero

Introduction

This document describes how to start Active-HDL simulator right from Microsemi Libero to run pre-synthesis, post-synthesis and post-layout simulations. This application note has been verified on Active-HDL 10.1 and up to Libero 11.5 series.

Installing Microsemi libraries in Active-HDL

In order to run the simulation successfully, depending on the design either VHDL or Verilog Microsemi libraries have to be installed in Active-HDL. You can check what libraries are currently installed in your Active-HDL using Library Manager tool. You can access Library Manager from the menu View | Library Manager. You can install precompiled Microsemi libraries in multiple ways:

  1. If you are using Active-HDL DVD to install the software, during the installation, you will get the option to select and install the Microsemi libraries

  2. If you have received a web link to download Active-HDL, on the same page you will find the links to download Microsemi libraries.

  3. Pre-compiled Active-HDL libraries are also available at Microsemi

  4. At any time you can visit the update center to download the latest Microsemi libraries at the Support Portal

Set Active-HDL as Simulator in Libero Design Flow

Once an Microsemi Libero project is opened, options for the Microsemi Libero project can be set in the Profile window (from main menu Project | Tool Profiles…) as shown in Figure 1.

Figure 1

In the Tool Profiles window, select Simulation and click on the plus (+) sign. To replace the default simulator with Active-HDL, please type Active-HDL in the Name field, select Active HDL as Tool integration and then click the Browse button to specify the location of Active-HDL executable. You will need to browse to the Active-HDL installation folder, go to the \BIN subfolder, and select the avhdl.exe file. Click OK. Figure 2 illustrates this.

Figure 2

If you are using Libero 9.1 and earlier: Under Addtional Parameters add the following -startup "C:\Aldec\Active-HDL\bin\Microsemi_libero_startup.do". Figure 3 illustrates this.

Figure 3

Active-HDL should now appear in the Tool Profiles selected as a default HDL simulator, see Figure 4.

Figure 4

Configuring your Libero Project Settings

Before running a simulation, you will need to prepare your Libero project with all needed HDL sources and also specify the proper stimulus. Once all HDL source files are in the Libero project, it is important that users go to menu Project | Project Settings... and click on the DO File option under the Simulation.

Figure 5

The libero tool is capable of launching Active-HDL simulation with automatically generated scripts (DO file). If you choose to do so, please make sure you select the proper values for:

  • Simulation runtime

  • Testbench module name

  • Top level instance name in the testbench

Configuring the Simulation Library settings

If your design is using any components from Microsemi device library you will have to set the right path for the library to be used. This is especially important in case if you are running timing (post-layout) simulation.

Go to the menu Project | Project Settings.... Under Simulation Libraries, select the target device.

  1. set library path to the location of the pre-compiled library in Active-HDL. For instance, C:/Aldec/Active-HDLxx.x/vlib/microsemi/vlog/igloo.

Figure 6

Now you should be ready to run your simulation in Active-HDL.

Starting Active-HDL from Libero

To start Active-HDL from Libero IDE, simply double-click the level of simulation as shown in Figure 7.

Figure 7

Active-HDL will be invoked. Compilation and simulation messages will be printed to the Console window. The waveform window will automatically open and signals will be traced as shown in Figure 8.

Figure 8

Please note the simulation control buttons (Run, Run Until, Run For and Active-HDL Restart Simulation) on top of the waveform window. You can use these buttons to control the simulation. For example, you can restart the simulation without leaving Active-HDL by clicking on the button for Restart Simulation.

Ask Us a Question
x

Ask Us a Question

x
Captcha ImageReload Captcha
Incorrect data entered.
Thank you! Your question has been submitted. Please allow 1-3 business days for someone to respond to your question.
Internal error occurred. Your question was not submitted. Please contact us using Feedback form.